What are the Server requirements to run Zen Cart?

Zen Cart v1.5.0

Minimum server requirements:

  • PHP 5.2.14 or higher, or PHP 5.3.5 or higher. Specifically, you should be using the latest PCI Compliant version as per PCI Standards.
  • Apache 2.x or newer (Specifically the latest PCI Compliant version)
  • MySQL 5 or higher (again, use a PCI Compliant version) (will work with MySQL 4.1.3)

NOTE: Many shipping and payment modules require CURL to be installed/compiled with PHP and OpenSSL.

NOTE: Support for https may be required depending on the payment methods being accepted. The use of SSL during account creation and checkout is recommended, and is a requirement for PA-DSS compliance.


PHP Version

Zen Cart v1.2.x through v1.3.6 are compatible with PHP 4.3.2 - 4.4.x.? They are NOT compatible with PHP 5.
Zen Cart v1.3.7-v1.3.8a are compatible with PHP 4.3.2 through PHP 5.2.x, but *not* PHP 5.3.
Zen Cart v1.3.9 series is compatible with PHP 5.3.2 thru PHP 5.3.xx.
Zen Cart v1.5.x is compatible with PHP 5.2.14 thru PHP 5.3.xx

NOTE: PHP 4.x is NO LONGER SUPPORTED by the PHP authors, and is largely deemed insecure by PCI standards. IT IS NOT RECOMMENDED TO USE PHP 4.x ON ANY LIVE SERVER.

  • Register Globals may be on or off, with "off" being the recommended configuration for security reasons
  • safe_mode off recommended, also for security reasons


MySQL Version

MySQL 5 is not officially supported by Zen cart v1.3.7 and lower.
However, shopowners running v1.3.6 and newer seem to be reasonably successful. MANY addons for v1.2.x and v1.3.x are not properly written to MySQL 5 standards, and as such may require alterations if you choose to use them.
Using the latest version of Zen Cart is always recommended for maximum compatibility.

Zen Cart v1.3.9 and v1.5.x are compatible with MySQL 4 and 5

Zen Cart v2.0 has been written with MySQL 5.1+ compatibility in mind.? Addon-compatibility may vary.


Zen Cart v2.x

Zen Cart v2.0 (currently in development) will have a different set of minimum requirements:

  • PHP 5.3.5 minimum, and compatible with PHP 5.4
  • CURL-with-SSL support compiled into PHP will be required
  • MySQL 5 required. (May be compatible with MySQL 4.x, but it's important to note that the MySQL authors are ending their support of old versions.)
  • SSL is recommended, and indeed required for PA-DSS compliance
NOTE: Use of HTTPS (ie: SSL) is highly recommended for the purpose of protecting the data you collect about your customers. Some payment modules require SSL in order to work, and using them without SSL is often a violation of your TOS with your merchant bank and of course of PCI compliance.
  • Register-Globals SHOULD be OFF
  • PHP safe mode should ALWAYS be OFF


  • 0 Users Found This Useful
Was this answer helpful?

Related Articles

Understanding the Override System

This article is based on material originally posted by Networkdad, DrByte and other...

Powered by WHMCompleteSolution